Red Deer Jeep Packrats

Central Alberta's Recreational Jeep Club
Home Page FAQ Team Search
  Register
Login 
View unanswered posts View active topics  

Delete all board cookies

All times are UTC - 7 hours [ DST ]




New Topic Post Reply  [ 4 posts ] 
  Print view
Previous topic | Next topic 
Author Message
Offline 
 Post subject: 4.0 timing troubles
PostPosted: Fri Jun 12, 2015 6:34 pm 
RDJP Member

Joined: Fri Apr 05, 2013 6:58 pm
Posts: 28
OK so here it is. Have a 92 Xj sport with cracked block but still ran. Pulled a 4.0 motor from a 99 ish Zj which also still ran. Pulled the intake, exhaust and distributor off as well because that stuff would not match up. So what I have now is a 99 block and head and all internals ....with 92 distributor, intake and exhaust and all electronics. All went well till I tried to fire it up....nothing. try as I might. ...no mater how many times I set it to TDC and install the distributor at 5 o'clock I get nothing. 1 tooth forward or back and it sputters but that's it. 

So my question is this...is the 99 internals that much different? Is the timing different? Can I even use this motor? Been at this for 2 months and about to set it on fire.....help please! 

OK. I think that it. Thx


Top
 Profile  
 
Offline 
 Post subject: Re: 4.0 timing troubles
PostPosted: Fri Jun 12, 2015 8:05 pm 
User avatar
Past President

Joined: Sat Dec 20, 2008 9:16 pm
Posts: 2866
Location: Sylvan Lake, Alberta
Did you strip off ALL the elctronics from the 1999? Because I know if you don't have the correct year, it's impossible to switch engines between WJs, let alone another model.


`48 CJ2A, `54 CJ3B, '13 Rubicon

My Willys is your TJ's daddy.....


Top
 Profile  
 
Offline 
 Post subject: Re: 4.0 timing troubles
PostPosted: Sat Jun 13, 2015 12:04 am 
RDJP Member

Joined: Fri Apr 05, 2013 6:58 pm
Posts: 28
no I did not but I can if that is what I must do....so that said....your saying the cam inside must be different for it not to run which is why I would need the newer ecm and sensors to make it work? that could b a problem as the crank sensor in the 99 auto trans will not fit the 5speed in the 92....I was hoping to avoid rewiring the whole damn thing....oh well...if I must I must...thx


Top
 Profile  
 
Offline 
 Post subject: Re: 4.0 timing troubles
PostPosted: Sat Jun 13, 2015 2:44 pm 
User avatar
Past President

Joined: Sat Dec 20, 2008 9:16 pm
Posts: 2866
Location: Sylvan Lake, Alberta
By no means am I an electrical wizard....electrical dunce, more like it. But I remember when I was looking for an engine for 2002 WJ, I ran across material stating that I needed to find the same year engine, same flywheel tooth count, etc.


`48 CJ2A, `54 CJ3B, '13 Rubicon

My Willys is your TJ's daddy.....


Top
 Profile  
 
Search for:
Display posts from previous:  Sort by  
New Topic Post Reply  [ 4 posts ] 

All times are UTC - 7 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum
Jump to:  

Powered by Skin-Lab © Alpha Trion